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SIwave Training
Signal and power Integrity analysis for 

complex PCBs and IC packages
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PACKAGE

HFSS™, Siwave™, Q3D,
Icepak®, Mechanical

BOARD

SIwave, HFSS, Q3D, 
Icepak

CONNECTOR
HFSS, Q3D

Analog IPs
Totem

DDR

HDMI

RF

FLASH

End-to-End Chip-Package-System
Power, Noise, Thermal, EMI, Timing Platform

Digital RTL
PowerArtist

CHIP

RedHawk

ANSYS Electronic Business Unit
Driving Chip-Package-System Convergence



© 2015 ANSYS, Inc. December 7, 20164

High Speed Digital Design Issues

Driver IC
Control IC Memory

Power Supplies

Display Panel

Signal Integrity
- Impedance
- Crosstalk
- Reflection
- Termination
- Dielectric Losses

Power Integrity
- DCIR drop
- Switching Noise (SSO/SSN)
- Impedance Profile
- Power/Gnd Plane Resonance
- Return Path discontinuities

EMI/EMC
- Common mode radiation
- Differential mode radiation

PCB

Pwr Noise

Signal
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Thermal

RH-CTA

Analog/IP

Totem

RTL

PowerArtist

SoC

RedHawk

SIwaveHFSS

Q3D (TPA) Solver Q3D Extractor

Nexxim HSPICE

CPA Solver

PSI Solver
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Thermal

RH-CTA

Analog/IP

Totem

RTL

PowerArtist

SoC

RedHawk

AC SYZDC

ALinks for EDA:
ECAD Translation

Signal Net Analyzer
Zo & X-talk Scans

Near/Far Field

Frequency Sweep

PI Advisor: Decoupling Optimization

Plane Resonance

Loop Inductance

SI Circuit Analyses:
IBIS, IBIS-AMI, Transient
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Functionality SIwave – DC SIwave – PI SIwave
ECAD Translation   

SIwave & 3D Layout GUI   

I2R DC solver   

DC Path Resistance Solver   

Leadframe Editor   

Plane Resonance Solver  

Automated Decoupling Analysis Optimization  

SYZ Solver  

Frequency Sweep Solver  

Synopsys HSPICE Integration  

AEDT Integration AC SYZ Solver Integration  

Zo & Crosstalk Scanner 

TDR Wizard 

Near-Field solver 

Far-Field Solver 

Signal Net Analyzer 

Circuit Analysis (IBIS, IBIS-AMI, QE, VE, …) 

PSPICE syntax model support in Nexxim 

N e w

N e w

N e w

N e w

SIwave
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ANSYS Typical SI/PI Design Flow

Electronic Design Environment
(Cadence, Mentor, Zuken, Altium ...)

Simulate & Extract Parasitics

Database Import
Geometry, Stack up, Components

SIwave/HFSS Model

Spice
S Parameter

Verilog-A
IBIS 5

IBIS AMI

Circuit Simulation

EM Model
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• Integrate Electrical CAD (ECAD) to ANSYS Software

• ANSYS ALinks for EDA (once called AnsoftLinks for ECAD) streamlines the transfer of 
design databases from popular third-party EDA layout tools into ANSYS 
electromagnetic, thermal and mechanical simulation products. EDA links are available 
for a number of tools offered by Altium, Cadence, Mentor Graphics, Sigrity and Zuken.

• This license give you access to an ANSYS menu in your layout tool (after installing 
ECADtranslator) and to the SIwave GUI to prepare your simulation project.

• Translator / Editor / Link from a 3rd party layout tool to ANSYS Solvers

What is ALinks for EDA ™ ?

Electronic Design Environment
(Cadence, Mentor, Zuken, Altium ...)

ANSYS Simulation 
Products
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Cadence
• Allegro  16.0, 16.1, 16.2, 16.3, 16.5, & 16.6
• APD  16.0, 16.1, 16.2, 16.3, 16.5, & 16.6
• SiP Digital/RF  16.0, 16.1, 16.2, 16.3, 16.5, & 16.6
• Virtuoso  5.10, 6.14, 6.15, & 6.16 (Linux only)

Mentor Graphics
• Expedition  v2005, v2007.1 thru EE7.9 (uses HKP design flow)
• Boardstation  8.x (uses HKP design flow)
• Boardstation XE  v2007, v2007.1, v2007.2, v2007.3 and v2007.7 (uses HKP design flow)
• PADS  PowerPCB v5.2a, v2005 and v2007 (ASCII Flow)

Zuken (Sold by Zuken)
• CR5000  10 and higher (Zuken translator for .anf & .cmp)
• CR8000  2013 and higher (Zuken translator for .anf & .cmp)

ODB++
• Altium Designer  R10 and greater
• Mentor Expedition  EE7.9.1 and greater
• Mentor PADS  9.4 and greater
• Zuken Cadstar  12.1 and greater

IPC-2581 
• Pulsonix  Revision 8.5 build 5905 and greater
• Altium Designer (BETA)  v2015 and greater

Other ECAD Formats
• .anf  ANSYS neutral file format
• .gds  IC Chip format
• .xfl  Apache Sentinel format
• .dxf  AutoCad drawing format

Added Lead Frame Editor capability to SIwave and ANSYS Electronics Desktop

Supported ECAD Translations
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Design Automation 
for Layout
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• Software needed for this training class

– ECADtranslator (for file translation), SIwave and ANSYS License Manager

– A user is able to download all of the above software from ANSYS Customer Portal.  Click on 
Download > Current Releases (17.x) and then choose “ANSYS Electromagnetics products” to 
select the above products.

• ANSYS License Manager installation

– ANSYS License Manager package on Tools section

– Specify license server during installation 

• ECAD translators

– ECADtranslator 17.x

• It is a common installation Add-on package that will install ANSYS menu in your layout tool. After 
ECADtranslator installation, a user should see an ANSYS menu item in Cadence Allegro SIP /APD and can 
translate a layout file to SIwave with Alinks or create an .anf file.

• SIwave installation

– Install Electronics primary package : All EM tools will be installed at the same time.

Software Installation
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Importing a Layout with ALinks from Mentor

• Path to import Mentor ODB++ layouts: 

• Import > Mentor Expedition Design > ODB++ (EE7.9.1 or later)



© 2015 ANSYS, Inc. December 7, 201614

Importing a Layout from a ODB++ Design 

• Path to import ODB++ layouts: 

• Import > ODB++ design
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Importing a Layout with ALinks from Zuken 

• The recommended path to import Zuken layouts: 

• Import > ANF…

• Otherwise use the ASCII files exported from Zuken ( .pcf & . Ftf )

• Import > Zuken CR5000 design…
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• Two Modes of Operation :

– Direct Launch from 3rd party layout tool

• Requires installation of ECAD Integrations executables ( ECADtranslator )

– Stand Alone Editor

• Export / Import of .ANF files

• Here is the view of this integration inside of Cadence APD

How to translate Cadence database to ANSYS tools?

Cadence Advanced

Package Designer (APD)

Access ANSYS Tools directly from 

Cadence APD 
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Cadence Layout Translation
• Before Integration

• After the Integration

1) Direct link to SIwave with Alinks

• Cadence and ANYS EM tools are available on the same machine

2) Write an .anf file and then import it into SIwave with Alinks

– Cadence and ANYS EM tools are installed

on different machine
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When to use *.anf file?
• Direct link from Cadence is not appropriate if SIwave is not installed on the 

same machine. *.anf (Ansoft Neutral File) is required :

• Select « Write Ansoft Neutral File v2 »

• To get all components, a .cmp file is also required :

• Select « Write SIwave Component File »

• Launch SIwave : 

• File > Import > ANF or Component File…
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Drag & Drop the Cadence project In SIwave

• Select Nets to import.
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SIwave GUI

• 3D model automatically created
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Overview of Siwave GUI 
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GUI Ease of Use Improvements
• Undo/Redo 
• Recent project history
• Net Selection Ease of Use

– Show only highlighted nets
– Automated differential net identification
– Automated extended net (ENET) identification
– Automated pwr/gnd identification

• Net Properties
– Net properties by hovering cursor
– Net filtering
– Detect close edges
– Measure 
– Check Net Length
– Calculate Electrical Properties (R, L, C, G, delay, Zo, …)
– Change Trace Width

• Color Mode
– Color by layer
– Color by net
– Control highlighting color
– Control background color
– Control lighting 

• Interactive Options
– Z Stretch 
– LMB Pan, Roller Zoom
– Dynamic Zoom or Fast Zoom
– View Cross-section
– Hot Keys (standard ALT/SHIFT/LMB commands)

SIwave GUI



© 2015 ANSYS, Inc. December 7, 201623

• Starting SIwave on Windows

– Click the Microsoft Start button 

– Select All Programs

– Select Ansys Electromatgnetics Suite 17.0

• ANSYS SIwave

• Or Double click on the icon on the Windows Desktop

• Starting SIwave on Linux, Go to the install directory  : 

/opt/AnsysEM/AnsysEM17.0/Linux64/

Siwave

GUI Controls – Desktop
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SIwave User Interface

Post processing
Results

Nets Components

3D Modeler

Messages

Properties

Errors/Warnings

Layer/Geometry
Visibility
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SIwave Workspaces

SIwave Visibility > Workspaces
• The SIwave window has several optional workspaces:

– Selection Filters

– Components

– Information/Errors/Warnings

– Messages

– Layers

– Nets (Single Ended, Differential, Extended, PWR/GND…)

– Properties

– Results

Each window can be Floating or Docking
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GUI Controls – View

Changing the View

• Toolbar

• Shortcuts
– Since changing the view is a frequently used operation, some useful shortcut keys exist.  Press the 

appropriate keys and drag the mouse with the left button pressed:

• ALT + Drag – Rotate

– In addition, there are 9 pre-defined view angles that can be selected by holding the ALT key and double clicking on 
the locations shown on the next page.

• Shift + Drag - Pan

• ALT + Shift + Drag – Dynamic Zoom

Top

Bottom

Right

Predefined View Angles

Left
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Layers Window

• Layer Selection

– Select the active layer by clicking on the circular radio button.  The active layer is important 
when geometry is being created in the SIwave interface

• Fill/Unfill Layers 

– Toggle between Opaque and

Wireframe layer views

• Show/Hide Layers

– Click the X to either view or hide a layer

• To select planes, traces, pads, vias or 
circuit elements in a particular layer, select the 
corresponding check boxes

• Click on the icons to hide or view all layers  

GUI Controls – Desktop

Fill/Unfill

Layers

Show/Hide

Layers Planes Traces Pads

Circuit 

ElementsActive Layer

Vias
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GUI Controls – Desktop
Selection Filter Window

• Check or uncheck boxes to select certain elements.  For example, all types of elements can be selected except for 
Nets since the box is unchecked

Components Window

• For manufacturer supplied components the name, series number, global parts, circuit elements, and pins can be 
viewed

• For local components (created and placed by the user) the part name, circuit elements and pins can be viewed
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GUI Controls – Desktop

Nets Window

• Select and Deselect Nets by clicking the checkbox.  Also, Nets can be selected and unselected 
by using a Regular Expression.   Note that the expression field is case sensitive and that both * 
and ? are supported.  In the following window BLT_* selects all of the BLT_DATA nets

• NOTE: The option Wild Cards must be selected in Tools > Options

Expression 

Field

Select Nets Push onto 

stack

Pop from 

stackUnselect Nets

Swap stack 

alphabetical 

order
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GUI Controls – Desktop
Properties Window

• Information displayed in the Properties Window will vary based on the type of object selected 

• Types of Objects that can be selected graphically in the Modeler Window:

– Circuit Elements

• Capacitors, Inductors, Resistors

• Ports, Voltage Probes, Current Sources, Voltage Sources

– Board Elements

• ICs

• IOs

• Discrete Devices

– Geometry

• Bond Wires, Pads, Planes, Traces, Vias

– Nets

Net Properties

Geometry Properties

Board Element PropertiesCircuit Element Properties
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GUI Controls – Desktop
• Geometry

• Bond Wires, Pads, Planes, Traces, Vias

• Nets

Net Properties

Geometry
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GUI Controls – Desktop

Information/Errors/Warning and Messages Window

• Messages

– General information related to various tasks will be displayed in the message window.

• Information/Errors/Warnings Window

– Errors must be corrected before running the simulation

– Warnings should be further investigated but SIwave will run the simulation

– Information messages should be reviewed 

Information Warning

Error
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Selecting Mode

Several selecting mode

• Home > Selection

• Right Mouse Button

Units :

• In the Toolbars, set the reference units
– Usefull for drawing, measurement…

Coordinate of the mouse

• In the Toolbars
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GUI Controls – Cursor Tool-tip

Cursor tool-tip shows information about the selected 
object: component, trace, net, device, etc
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GUI Controls – Via Properties
• Via Properties

– Graphically select a via in the layout then select the menu item 

• Edit > Via… to bring up the Via Properties Window

– Editing the properties in this window will override the padstack definition.   For example, if a user would like 
to investigate whether or not to backdrill a via on a high-speed net the bottom layer can be changed.  The 
antipad definition for a particular via can also be investigated without having to change the parameters of all 
of the other vias that share the same padstack

– Pin Info provides the Type, Layer, Part Name, Reference Designator and Pin Name for the selected pad.  The 
Part Name, Reference Designator and Pin Names can be edited from here as well
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SIwave GUI Controls – Results

• Plot Self terms or Transmission terms

• Click on “Select self terms” to quickly plot all the self term

• Ideal to plot all the “Reflexions” of the S parameters matrix.
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GUI Controls –Script Commands

Any script language that supports ActiveX objects may be used:

• VBScript

• Jscript

• Python

Extensive scripting support allows automation.

Online Help 

• Script Commands are available
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GUI Controls Visualization 
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GUI Controls – Visualization 

Performing Faster Transformations

• SIwave allows you to view a simplified model during rotate, zoom or pan operations. 

• View>Faster Rotate.

Planes are represented in 2D, while vias and circuit elements are not displayed while 
you are rotating, zooming or panning in. The complete design is displayed only after 
you finish the operation.

Before and After Rotation During Rotation
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GUI Controls – Visualization 

A user can toggle between the net 
and layer color modes

Layer Color Mode Net Color Mode



© 2015 ANSYS, Inc. December 7, 201641

GUI Controls – Visualization 

• Object properties window
• Same options available using a right-click on the net list.

Net selected

A dockable window displays the 
properties of the selected object

Only the selected net will be 
visible

Toggling between 
two color modes

For nets, users can change the net 
name, color, color mode and net 
visibility options
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• Changing opaque view  by setting Translucency for all metal

• Select all > METAL layers > Apply

• Set Translucency to 70% > update

• Better 3D visualization and rotation

GUI Controls – Visualization 
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GUI Controls – Visualization 

View > Compute Cross Section

• Draw a clipping line

• View > Back To Full Design
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• View > View Options
– Z Stretch– artificially scale Z values so that very thin planar objects have a 3D appearance.  

Choose any discrete value between 1 to 25

– Change Selection Color - change default selection color (yellow)

– Circuit Element Size - change the scale factor for circuit elements

– Gradient Background  - change default background colors

– Lighting – change the Brightness and Contrast

GUI Controls – Visualization 
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GUI Controls – Visualization 

• Stretching Z :
– To artificially scale Z values, so that very thin planar objects have a 3D appearance.

– View>View Options>Z Stretch.

– Choose any discrete value between 1 to 25, as the scaling factor.

Original view : scaling factor = 1 Original view : scaling factor = 10
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GUI Controls – Simplify Visualization 

• View > Simplify Circuit Elements

• View > Simplify Vias
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GUI Controls – Simplify Visualization 

• View > Layers > 2D View

• Unfill All layers by clicking on the yellow rectangle in Layer workspace
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Run in Remote

• To improve the response time when SIwave is running over a remote 
desktop:

– OpenGL management is mandatory to support 3D

– Informational tooltips will not appear.

– Dynamic zoom is deactivated.

– Faster transformation is activated.

– Simplify all visualizations settings :
• Vias

• Circuit Elements

• 2D view for layers

– Use Translucency / Unfill layers
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Batch mode
Syntax for SIwave: 

<path to>/siwave -exec_eigen <path to>/<project name>.siw

The following flags are supported:

-exec_eigen

-exec_syz

-exec_ac

-exec_dc

Examples : 

C:\instaldir\siwave -exec_syz D:\Examples\Midplane.siw

C:\instaldir\siwave -exec_eigen D:\Examples\switch.siw

C:\instaldir\siwave -exec_dc D:\Examples\Blade.siw

ExecAcSim
ExecResModeSim
ExecPdnSim
ExecPsiPdnSim
ExecSyzSim
ExecSentinelPsiSyzSim
ExecSentinelPsiAcSim
ExecFfSim
ExecNfSim
ExecDcSim
ExecFwsSim
ExecPiOptSim
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In R16, siwave_ng can be used as follows :
• This command, in addition to executing a requested simulation type, creates the necessary directory hierarchy and 

.asol file such that results can be post-processed in the UI after the siwave_ng run completes.

siwave_ng <path to .siw> <path to .exec> -formatOutput –useSubdir

Non graphical Batch solve command

Example :
C:\Program Files\AnsysEM\AnsysEM16.2\Win64\siwave_ng C:\projects\ssn.siw C:\test\execsyz.txt -useSubdir

ExecSyzSim
SetSwp 5e3 5e9 500 Linear

The .exec file, at the very least, should contain one of the 
following strings (which specify the type of analysis to execute):

ExecAcSim
ExecResModeSim
ExecPdnSim
ExecPsiPdnSim
ExecSyzSim
ExecSentinelPsiSyzSim
ExecSentinelPsiAcSim
ExecFfSim
ExecNfSim
ExecDcSim
ExecFwsSim
ExecPiOptSim

This file can also (optionally) contain commands to modify the 
sweep, change the number of CPUs, the licensing scheme, etc.:

SetSwp
SetNumCpus
AddSwp
SetInterpSwp
SetDiscreteSwp
InterpSwpCvg
NumInterpPts
EnableQ3dDomains
WaitForLicense
DistributeSIwaveSyz
HpcHostName
ComputeExactDcPt
SolverMemLimit
UseHpcLicenses
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Non graphical Batch solve in detail

• SetSwp <f_start> <f_end> <num_pts> <linear/log/linear step

SetSwp 0 1e9 100 Linear

• AddSwp <f_start> <f_end> <num_pts> <linear/log/linear step>
- use this like you are adding another sweep line in the UI; allows for changes to the 
number of points & the distribution type

- use in conjunction with SetSwp

SetSwp 0 1000 10 Log

AddSwp 1000 5e9 500 Linear

• SetNumCpus <number>

SetNumCpus 4

• SetDiscreteSwp
- no argument; just tells the simulation to use a discrete sweep for the sweep setup in 
the UI
- can also use in conjunction with SetSwp

SetSwp 0 1e9 100 Linear

SetDiscreteSwp

• SetInterpSwp
- no argument; just tells the simulation to use an interpolating sweep for the sweep
setup in the UI
- can also use in conjunction with SetSwp

SetSwp 0 1e9 100 Linear

SetInterpSwp

• InterpSwpCvg <Relative error for S>
InterpSwpCvg 0.005

• NumInterpPts <num_points>
- number of points to be explicitly solved for during the interpolating sweep

NumInterpPts 30

• UseHpcLicenses <pack | pool>
- SolverMemLimit <% of memory to be used by the solver on a machine when using a HPC 
License>

UseHpcLicenses pack
SolverMemoryLimit 80 

• ComputeExactDcPt <boolean>
ComputeExactDcPt 1

• EnableQ3dDomains <boolean>
EnableQ3dDomains 1

• WaitForLicense <boolean>
WaitForLicense 1

• DistributeSIwaveSyz
no argument required

• HpcHostName <machine_name|IP address> <CPUs_to_use> <%Memory>
- use in conjunction with DistributeSIwaveSyz
- can use this command to enter multiple machines

DistributeSIwaveSyz
HpcHostName \\machineA 6 80
HpcHostName \\machineB 6 80

HpcHostName \\machineC 6 80
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Stack up, Padstack, 
Balls/Bumps, Bondwire
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Layer Stack-up Editor

• All layers are imported with material properties and thickness

• Possible to edit and export/import the Layer stackup (“.stk” file)

• File > export > Export Layer Stackup



© 2015 ANSYS, Inc. December 7, 201654

Material
• Easily change the material properties using the predefined Material library of 

SIwave or Add a new one.

• Add a new Material 
• You can click on Edit Material Properties > Add… or go to Home > Edit Materials
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Materials – View / Edit /Create
• Materials

– View existing material properties or create a new material

– Make sure that the correct material, Conductor or Dielectric, is selected then click the Add button to 
create a new material

• Dielectrics
– Choose which dielectric material model to use

– The preferred Djordjevic-Sarkar model is a causal frequency-dependent dielectric model developed 
specifically to model FR-4.  It is also useful for many other low-loss insulator materials. The Debye model 
characterizes a lossy dielectric material by two measured values at a certain frequency.  (More detailed 
information on both of these models can be found in the SIwave Help) 
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Material - Frequency dependent parameter

     

0

ln
)ln( 














jj

j

j

A

B

AB



















• Have to consider :

• Conductor loss

– Skin Effect

• Dielectric constant and loss

– Djordjević-Sarkar model
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Frequency dependent models are default
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Modeling of Traces

• Define Trace Cross Section by choosing the appropriate 
shape by layer:

• Rectangular, Trapezoidal and hexagonal

• Edit > Trace Cross Section…

Rectangle Trapezoid Hexagon
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• Display the electrical properties of the selected transmission line in real time.
• Selecting mode should be on “object”
• In the properties window, click on Display

Trace Electrical Properties
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Bondwire Electrical Properties
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Padstack Editor
• Padstacks describe the stacking structure of shapes associated with pads and vias. They enable different 
shapes on different layers and contain drill information, plane layer information, and inner layer 
information.  In the editor, padstacks can be added, modified or deleted

• Home > Edit Padstacks
• Select a padstack to view its properties.  If a via is selected in layout it will automatically be highlighted 
when the Padstack Editor is launched
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SolderBall Generation

• Home > Solderball Properties

• Choose padstack and Enter Type, Radius and Height

Creation of the solderballs and add a PCB layer
• Update the stackup

( replace FR4 by Air)
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Bondwire Generation

• Bondwire models can be assigned to the layers in the stackup. This command is active only when 
at least one layer has the type WIREBOND. You can edit the layer properties to change the layer 
type.

• Because bondwires are modeled as traces, you first need to draw a trace before creating a 
bondwire.

• Edit > Bondwire Model
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Bondwire Model
• Bondwire type 

– Several models are available :

Stub

JEDEC 4-Point JEDEC 5-Point

Low Profile

Flip Profile Across XY-Plane

Reverse Package and Die
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User Defined Bondwire for SiP

• For Bondwire profile, it is common to use JEDEC 4 or 5 points, but this can cause collision 
problem for stacked dies in SiP.

• With User Defined Bondwires is it possible to draw every kind of profile from sketch (user can 
also edit, save or import his own profile)
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Custom Bondwire Profile
• Edit > Bondwire Model…

• Create a custom bondwire profile by entering points or importing coordinates from a file.  The 
.bwp (bondwire profile) can be imported for use in other projects.  Click the Update Bondwire
Diagram button to refresh the sketch
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Expanded Bondwire Options

• Die-to-die

• Cascaded

• Trace-to-trace
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Relocate Bondwires

• Tools > Relocate Bondwires…

• One isolated Bondwire « VDD_LNA » on Layer ‘WB11’

• Relocate it on ‘WB22’ layer using « Relocate Bondwires » utility
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Drawing Mode
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Drawing Mode (1/2)

To modify the layout, you can specify various options for drawing two or more 
geometric shapes. The shapes can be either added without merging, or merged, or 
subtracted. 

Select one of the three mode

• Draw > Drawing Mode

– Add (No Merge) : To draw and display multiple objects together. No union between each 
shape primitive and different “net name”.

– Merge : To draw and display multiple objects as one merged object. Same “net name”.

– Subtract : An existing geometry can be modified by drilling holes in it or by removing some 
elements from it. The area of the geometrical shape is cut out from the main Drawing Area.
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Drawing Mode (2/2)

Select the drawing layer in the Layers Workspace

Select a primitive :

• Circle (Shortcut Key: F5)

• Polygon (Shortcut Key: F6)

• Rectangle (Shortcut Key: F7)

• Trace (Shortcut Key: F8)

• Via (Shortcut Key: F9)

Note 1 : To draw a Trace

• Specify the width before
– Draw > Set Trace Width…

Note 2 : To draw a Via

• Select a Padstack before
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Measuring Data

• SIwave allows you to measure the distance between points and spacing 
between edges.

• To measure data :

• Click Tools>Measure. The Measure Data dockable window 
appears.

• To measure the distance between two points: Click any point for a 
reference coordinate. This is displayed as Position 1. Move the 
cursor in the Drawing Area to see the values for Position 2 and 
Distance between Points. The data updates as the cursor is moved. 
The shape of the cursor changes when it is snapped to a corner or 
mid-point.

• To measure the shortest distance between two edges: Select an 
edge in the Drawing Area. This is displayed as the Reference Edge. 
Move the cursor over another edge to see the values for Current 
Edge and Shortest Distance.



© 2015 ANSYS, Inc. December 7, 201672

Computing Net Length

• You can compute the lengths of all possible paths in a net, and also 
calculate the distance between any two net nodes.

• Tools > Compute Net Lengths or « Compute » button in the properties
window
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Operations on Plane

• Boolean operations can be performed on planes. You can unite, 
intersect or subtract planes. 

Eg : Uniting Planes

• Select the two planes that you want to unite.

• Click Edit>Boolean Operations>Unite.
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Edit Trace/Bondwire center line properties

• Trace/Bondwire

– To edit a bondwire first graphically select a bondwire in the layout.  Bondwire coordinates can 
be edited.  The bondwire radius is also displayed
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Edit Plane / Solderball properties
• Plane (Boundary/Cutout)

– Manually edit plane boundaries.  To activate this 
option graphically select a plane

• Solderballs

– Create solderballs and/or solderbumps on 
packages.  Choose the Padstack on which to 
create the balls and the radius and height
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Clipping the Design

• SIwave provides you with the option to cut out and view a particular region 
of the design, and ignore the rest of the geometry .

• Edit > Clip Design

• Follow the 6 steps > Clip
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Create a custom Reference Designator
• How to create your own reference designator inside SIwave UI ?

1. Select via(s)/pad(s) of interest (those you wish to classify as belonging to a part/ref des.).

2. Right-click and select "Properties" in the pop-up menu.
3. In the "Via Properties" dialog set the following under the "Pin Info" section: 

- Type (either BGA or DIE)
- Part name (any reasonable string)
- Reference designator (any reasonable string)
- Pin name (any reasonable string).  

-This field is disabled if more than one pad/via has been selected; 
in this case, pin names are automatically generated (“1", “1", ...) 
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3D Export
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How to do a 3D export?

1. Identify Power and Ground nets 
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How to do a 3D export?

2. Select Nets you wish to simulate 
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How to do a 3D export?

3. Define Plane Extents
• Automatic

– Simple 
– Precise
– Type a clip distance

• Manual
– Draw Polygon
– Draw Rectangle 
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What is a Plane Extent? 

– Plane extents define the region that will be cutout when exporting to HFSS, Q3D Extractor, ANSYS 
Workbench, or Designer. 

– Plane extents define the region that will be cutout for inclusion within an HFSS solve 

– Plane extent operations

• Users must first define power and ground nets. This allows a cutout on those nets when trying to 
simulate signal nets. 
• Plane extents can be created automatically or manually 
– Automatic Plane Extents
• Define the extent you want the cutout to extend beyond the signal traces (mm, um, mils, 
inches, …) 

• Simple: Creates polygon cutout without Arcs 
• Precise: Creates polygon cutout with Arcs 

– Automatic Plane Extents to Terminals 
• Defines the extents to Wirebond, Solderball/Solderbump

• Simple: Creates polygon cutout without Arcs 
• Precise: Creates polygon cutout with Arcs 

– Manual Plane Extents
• User draws a plane extent in the layout editor window 

• Rectangle: Creates rectangular cutouts
• Polygon: Creates polygon cutouts
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How to do a 3D export?

4. Go to Export > Preview Export (Clipped PWR/GND) 



© 2015 ANSYS, Inc. December 7, 201684

How to do a 3D export?

5. Export to HFSS, Q3D Extractor, Designer or ANSYS Workbench 

HFSS 3D LAYOUT
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Validation check
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SIwave : Validation check  

• Before you run an analysis on a model, it is very important that you first perform a validation 
check on the project. When you perform a validation check on a project, SIwave runs a check on 
all the setup details of the active project to verify that all the necessary steps have been 
completed and their parameters are reasonable.

Performing a Validation Check

• Tools > Validation Check.

• Self-Intersecting Polygons 

– Check for duplicating planes, intersecting edges, and check if 
voids intersect the plane boundaries.

• Disjoint Nets 

– Check if there are any nets that are not completely 
connected.

• DC-Shorted Errors

– Check if any nets overlap.

• Identical/Overlapping Vias

– Check if any vias are identical or overlap on the same nets.
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SIwave : Validation check 
• Bondwire Collisions

– Check for duplicate or overlapping bondwires.

• Illegal Connections of Bondwires

– Check if the inner radius of the via is more than the bondwire, or if the bondwire extends 
through the pad.

• Misalignments 

– Check for all misalignments, in the following cases:

• to flag and auto-correct areas where the centerline of a trace is not contained within a plane. 

• if a trace overlaps with a plane, but the centerline of a trace doses not intersect with a plane.

• if a trace overlaps with other trace, but the centerline of a trace does not intersect with the centerline of 
other trace.

• if the boundary of a pad/via intersect with the boundary of a trace, but the center of a via/pad is not 
located on the centerline of a trace (in other words, the pad/via is not snapped to the centerline of a 
trace).

• if the boundary of a plane intersect with the boundary of a pad/via, but the center of the pad/via is not 
contained in the boundary of the plane.

• Unreferenced Trace Segments

– Check for traces with no reference plane above or below it. 
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Validation Check : Disjoint Nets

• Definition of a Net : A ‘net’ is a continues piece of metal. If two pieces of metal that 
are defined to be the same net are not DC shorted an error can occur .

• Disjoint Nets 

– Check if there are any nets that are not completely connected and highlights trouble with electrical 
connections.

– A very common problem that arises sometimes is that piece of metal that have been added as shield are not 
physically connected to ground. These floating pieces of ground pour can actually serve as a radiating 
structure rather than provide effective shielding as the engineer was intending.  Any floating pieces of metal 
should be connected through vias/additional metal or removed from layout.

• To fix the disjoint nets
– Expand the Disjoint Nets error message

– The net GND has been identified as having disjoint geometry. Select this net from the nets listing

– Select Edit -> Nets -> Separate Disjoint Parts

– Click OK  to the resultant message window.

– Scroll down the nets window and notice that additional nets were created from the disjoint pieces, net-1, net—2,….
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Validation check : Identical / Overlapping Vias

Identical/Overlapping Vias
• Check if any vias are identical or overlap on the same nets.
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Validation Check : Misalignments

Misalignments :

Auto Fix

• Traces-Inside-Traces Errors :
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Nets options

• Edit > Nets 
– Most of the Nets options are used to correct geometry that has been imported from a third-party layout 

tool.  It is useful to first run a Validation Check (which will be described later in this section) to detect 
potential issues

– Merge

• All Selected Nets

– Merges all electrically connected nets that have been selected

• Connected Nets

– Merges all electrically connected nets in the set into a single net.  It is not necessary to manually select these nets 

– Check if Disjoint

• Only checks the selected nets.  The complete layout can be checked during the Validation Check

– Check for DC Short

• Only checks the selected nets.  The complete layout can be checked during the Validation Check

– Separate Disjoint Parts

• If all parts of a net are not electrically connected this operation will allow these parts to be separated into different nets

– Misalignment

• Select and View

– No operation is performed, this is a visualization only

• Correct

– SIwave will try to correct the alignment.  The misalignment will be detected in the Validation check.  This occurs when 
a design has traces whose center lines are not connected to any planes or pads or the center lines of other traces 

– Change Name

– Enter a new name
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Disjoint Nets

Original : The two pads look to be connected For solver setup, the arcs are discretized
and so they are not connected.

The auto fix can't separate the disjoint nets, 
but the validation check will point the 
separating locations of disjoint nets
If a trace connecting two pads in the design is
added manually, the net gets well-connected.
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SIwave GUI Controls – Results
SIwave Desktop : Results Window
• Users can define solve, and post-process multiple resonant mode, frequency, SYZ, etc., simulations

• Simulation results are no longer stored in the *.siw file but rather are stored in the *.siwaveresults
subdirectory.  Far-field results and network parameters are accessed from the desktop

• One quick integrated reporter with S,Y,Z tab

• Results can be exported to AEDT for post-processing

• Results can also be exported to NdE for causality/passivity check
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Circuit Element
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SIwave Circuit Element Parameters

Home > Circuit Element Parameters
• For manufacturer supplied components: you can see the manufacturer name, series number, 

global parts, circuit elements, and pins.

• For local components (created and placed by you): you can see the part name, circuit elements 
and pins.
– Next to each pin number, you can see the net to which it is attached.

Set Active or Set Not Active

A green check mark in front of 
the element shows that it is 
active and will be included in 
the analysis. A red cross shows 
that is inactive.
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Passive components
• Direct import of passive component

Choosing appropriate model
• Three methodologies :

• Ideal resistor, inductors and capacitors

• TouchStone representation of Capacitors, 

Inductors, Resistors, and ICs

– Vendor libraries of commonly used 

components (ESR, ESL included)

• Equation based RLC parasitics

– User defines parasitics at specific frequency
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Examine Component Properties

• If you have a global part name selected: you can examine component properties, 
plot the component’s impedance vs. frequency graph, or place a component 
either on the top layer or bottom layer
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To launch the Component Management dialog

• Tools > S-Parameter Model Assignment…

• Matching can be done :

– Automatically by Matching part names or values 

– Click Auto Match By Value... or Auto Match By Name...

– Using a matching File :

– Click Import Part Matching File …

SIwave : Component Management
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SIwave : Part Matching File

In the Component Management dialog

• Import Part Matching File
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SIwave : Part mapping file

Part Matching from Part Number

The vendor part number in the 
BOM may not be an exact match 
to a value in the library.

Wide-band scattering-
parameter models are
automatically assigned
from the SIwave library.
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SIwave : part mapping file

* Syntax for specifying parts: 

<part name> <type> <val> <pin order>

which gives little clue as to supported strings for the <type>, <val>, & < pin 
order> fields

There is a component mapping file that has the format like this:
# <partname> <ParasiticCap> <ParasiticInd> <ParasiticRes>
R_PAK_0402X4-15,5%,31.25MW,N/AA Res 1.500000e+01
R_0603-750,1%,1/16W,N/A-1%,1/1A Res 7.500000e+02
R_0603-75,1%,1/16W,N/A-1%,1/16A Res 7.500000e+01
R_0603-7.5K,5%,1/16W,N/A-1/16WA Res 7.500000e+03

Which can be exported through File > Export > Component Mapping File

Then there is a PMAP file which has the format:

<CustomerPartNumber> <Type> <Vendor> <Family> <PartNumber>



© 2015 ANSYS, Inc. December 7, 2016102

• So if the customer has a part number called CUST203204932 which is a 0201 cap 
that would map to an AVX capacitor family 0201 part number <0201YA390JA>:

• Then the Customer.PMAP file would be a text file that would have then entry:

• CUST203204932 Capacitors AVX 0201 0201YA390JA

• This file would perform the mapping under the Tools à Component Database à Part 
Matching File

Example : part mapping file
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Ports are similar to probes 

in lab measurements

To Perform a circuit 

extraction or SI 

analysis, place ports 

in desired location

SIwave : Port Assignment
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SIwave : Manually draw a Port

• Top-Down view must be activated

• Circuit Elements > Add Port

• Click 2 times to define the positive and negative pin.

• Define the Positive and Negative Terminals

by choosing a layer

• A port can be placed everywhere
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• Generate the port on the selected net

• Select the net(s) 

• Tools > Generate on Selected net…

SIwave : Generate on selected net
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• Generate port on component
• Select a component

• Tools > Generate on Component…

• Define Positive and Reference terminal

SIwave : Generate on Component
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SIwave : Create Differential Pairs 

• Make sure that the Differential workspace is checked :

• Visibility > Workspaces > Differential Nets

• This area allows you to define, search, sort and remove the differential pairs.  

• An Auto Identify feature find differential pairs using the positive and neagtive net suffix.

• Define + & - net suffix

• Auto Identify  
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SIwave : Create Extented Nets (E Net) 

• Make sure that the Enet workspace is checked :

• Visibility > Workspaces > Extended Net

• This area allows you to define, search, sort and remove the Enets. Most extended nets in 
real usage consist of only 2 nets with names like “NET1” and “NET1_R” connected by a 
resistor. 

• An Auto Identify feature find Extended net using a keyword (i.e. the net name 
differentiator) should be just “_R”
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Classic questions 
about Port Settings 
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Classic questions about Port Settings 

• What if a port in SIwave does not have a connection to a 
reference plane, but is connected between two signal 
locations? Does this invalidate the results?

• S-parameter models generally consist of ports referenced 
to ground. 

• In DesignerSI, the S-parameter symbol is often in is an 
“implied reference to ground” format.
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A Simple Example

• Consider a 2-inch long trace over a reference plane.
– Ports P1 and P2 between the trace and plane at each end

P1 P2

• Model in AEDT, with a source at P1 and P2 shorted to 
ground:



© 2015 ANSYS, Inc. December 7, 2016113

TDR Results

• Source drives a 100ps edge

TDR edge
Reflection from 
far-end short

Round-trip 
prop delay
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Now Split the Trace In Two…

• Now two traces of roughly 1 inch in length

• Ports to ground at all trace ends

P1 P2 P3 P4

• Connect a series 
inductor between P2 
and P3
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Series Inductor Results

• Inductor causes small positive reflection in the middle of 
the waveform

• Results still perfectly intuitive
Inductive 
reflection

Roughly the 
same round 
trip time
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Now Place Just One Port In the Middle

• Same pair of 1-inch traces, but now place a single port P2 
across the gap between them. 

– No connection to reference plane at P2

P1 P2 P3Cross-section

P2 positive
terminal

P2 reference
terminal

In the circuit schematic, we only have 
one pin.  How do we connect the series 
inductor?
If we connect it between the P2 
terminal and circuit ground, will that 
short out the second trace?
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No.  Results Are The Same

• Voltage between node P2 
and circuit ground 
corresponds to voltage 
across the positive and 
reference terminals of the 
SIwave port

• Circuit ground and physical 
reference plane are 
completely different things
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SIwave Solvers
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SIwave Solver Technology

SIwave solver components:

Plane model

2D FEM approach 
with triangular 

mesh

Results

• SYZ parameters
• Near and far field
• Resonance analysis

System Matrix
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Plane Handling

2D restriction offers a major speed and memory advantage

Same FEM technology as 
HFSS, but for layered 
structures, i.e. 2D non-
uniform mesh

),(ˆ),(ˆ yxHyxH yx yxH 

),(ˆ yxEzzE 

E Power and/or ground planes

Separation between the 

metal planes is much less 
than the wavelength
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2-D Full-wave FEM continued

• The Maxwell’s equations can be reduced to a wave equation 
in terms of the voltage difference between planes. 

 yxEz ,ẑE 

    IyxVCjGyxV
LjR




,)(,
1 2 


• The pre-processor identifies where the assumption is valid

E

Special case
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SIwave is a Hybrid Solver
• The pre-processor validates the layout, identifies and

categorizes structures, assembles matrix and passes to
sparse matrix solver.

• When is not valid?

– Traces

– Trace-plane coupling

– Via transitions

– Plane edges

– Bondwires, balls, bumps

– Coaxial probes

SIwave - Hybrid Solver

 yxEz ,ẑE 
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Correct Handling of All Plane Effects and 
Dielectric Losses

Frequency-dependent plane impedance

Correct Handling of Dielectric Losses

• Loss tangent and permittivity vary with frequency in a coordinated way

• Djordjević-Sarkar model
– Satisfies causality laws -> physically realistic behavior 

log(f)

log R(f)

fRac

dcR

log(f)

L(f)

acL

dcL
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MoM Modeling of Traces

2D MoM RLCG trace extraction

• Generalized multilayer extraction

– Transmission lines

– CPW

– Split planes

• Non-uniform material stackups

• Trapezoidal and hexagonal cross-sections

• High accuracy and speed

– Adaptive meshing of the trace cross-sections

– Fast frequency sweep acceleration

• Multithreaded solve capability with perfect scaling

• Automatic coupling based on dB threshold
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SIwave Modeling of Traces

• Define Trace Cross Section by choosing the appropriate 
shape by layer:

• Rectangular, Trapezoidal and hexagonal

• Edit > Trace Cross Section…

Rectangle Trapezoid
Hexagon
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Additional Solver Capabilities…

Vias
• Quasi-static FEM.  Recognize repeated structures and solve only once.

Plane edges: edge-edge coupling
• 2D-MoM.  Similar to transmission line modeling

Plane edge to trace coupling
• 2D-MoM

Low frequency plane-plane coupling

Passive components (RLC or s-parameters)

Bondwires & Balls and bumps
• Fast quasi-static 3D MoM (or Boundary Element Method)

Efficient, accurate full-wave analysis of complex PCB‘s is possible due to
• Sophisticated „pre-processing“ that properly recognizes and categorizes 3D 

features.

• Multiple EM solvers working in combination.

• Advanced Numerics (Matrix solver)
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SIwave Solver Components

Further models for improved accuracy:

• Fringe fields: correction for thin planes                                                       
(very critical for inductance!).

• Smart coupling detection: coupling between traces/plane edges and via 
coupling.

• Coplanes, split planes and thin planes: plane – plane and trace plane 
coupling.

Split CPW
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Single Through Via Single Through Via + Ground Via
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SIwave - Via Modeling
New VIA library - IBM Benchmark Examples

Taken From: Selli, G., et al, “Developing a ‘Physical’ Model for Vias,” DesignCon 2007
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• Board level - Via Stub effect

Back Drilling : 
remove the unused 
portion of PTHVia Stub Effect

High-Speed Memory System
Design Issues : Via Stub effect 
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Bondwires

A 3D method of moments solver is used to 
extract the RLC parasitics, including self 
and mutual terms 
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Passive Components

Component attachment accurately 
modeled from pad dimensions

ESR ESL

C

Ferrites included as a Touchstone 
model

• RLC components can be modeled 
as:

• Lumped Element 

• Touchstone file
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Simulation Options
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Global Simulation Options

Simulations > Options…
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SIwave - Mesh
Use FEM Discretization

Mesh Refinement. This parameter controls how the finite element mesh used in 
SIwave is generated. You can select from the following options:

• Automatic: This options automatically picks the suitable mesh refinement frequency. 
It is dependent on the drawing size, the number of modes, and/or the maximum 
sweep frequency. This is the recommended option.

• Frequency: This option lets you control the mesh size and is based on the effective 
wavelength of the specified frequency. 

Automatic : Fmax = 10GHzFrequency = 5GHz
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3D return current distribution
• 3D return current distribution check box if you want to accurately model the 

change of the characteristic impedance of transmission lines caused by a 
discontinuous ground plane. Instead of injecting the return current of a trace into 
a single point on the ground plane, the return current for a high impedance trace 
is now spread out. 

• The trace return current is not distributed when all traces attached to a node 
have a characteristic impedance of less than 75 ohms, or if the difference 
between two connected traces is less than 25 ohms.

– Not really necessary for PI relatedsimulations.

– For SI analysis it is quite useful and improves accuracy.

– Slow down the simulation noticeably. RAM is slightly increase by more matrix entries and 
some other overhead.
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Solver Coupling Options 

– By default, all coupling options are disabled. Please check the box Custom 
in the SI/PI tab to enable them.

Coupling Options in SIwave
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Case 1 – 1 trace, 1 plane
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With and without Split Plane Coupling

– With all the options enabled, SIwave calculates coupling between trace2 
and GND_left

– When Split Plane is disabled there is no coupling between the two

Coupling – Split Plane 

trace 2 GND_left
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With and without Split Plane Coupling
– With all the options enabled, SIwave calculates coupling between trace2 and GND_left

– When Split Plane is disabled there is no coupling between the trace2 and GND_left

Coupling – Split Plane – Two Cases

All Options

Split Plane Disabled
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Case 2 – 1 trace, 2 planes
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With and without Split Plane Coupling

– With all the options enabled, SIwave calculates all coupling including coupling 
between narrow planes like plane_2 and traces like trace_1

– When Split Plane Coupling is disabled, there is no direct coupling between 
trace_1 and plane_2

Coupling – Split Plane

Trace Narrow Plane GND_plane
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With and Without Split Plane Coupling

– Only coupling between the trace and GND plane are significant

Coupling – Split Plane
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With and without Coplane Coupling

– When Split Plane Coupling is disabled, there is no direct coupling between trace_1 
and plane_2

– If Coplane is also disabled, no coupling is computed between traces and planes

Coupling – Coplane

Trace Narrow Plane GND_plane
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With and Without Coplane Coupling

– Only coupling between the planes, plane_2 and GND are reported when Coplane is 
disabled

Coupling – Coplane
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Case 3 – 2 traces, 1 plane
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With and without Trace Coupling

Coupling – Trace

Trace_1 Trace_2 GND
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• For the Two Trace Model the results are the same as the Split Plane Enabled

• Disabling the Coplane excludes the coupling between each trace and the ground

Split Plane and Coplane Two Trace Model
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Freq [GHz] db(S(GND,trace_1))
SYZ Sweep no trace two trace model

db(S(GND,trace_2))
SYZ Sweep no trace two trace model

db(S(trace_1,trace_2))
SYZ Sweep no trace two trace model

1 0.001000 -inf -inf -inf

2 0.010998 -inf -inf -inf

3 0.020996 -inf -inf -inf

4 0.030994 -inf -inf -inf

5 0.040992 -inf -inf -inf

6 0.050990 -inf -inf -inf

7 0.060988 -inf -inf -inf

8 0.070986 -inf -inf -inf

9 0.080984 -inf -inf -inf

10 0.090982 -inf -inf -inf

11 0.100980 -inf -inf -inf

12 0.110978 -inf -inf -inf

13 0.120976 -inf -inf -inf

14 0.130974 -inf -inf -inf

15 0.140972 -inf -inf -inf

16 0.150970 -inf -inf -inf

17 0.160968 -inf -inf -inf

18 0.170966 -inf -inf -inf

19 0.180964 -inf -inf -inf

20 0.190962 -inf -inf -inf

21 0.200960 -inf -inf -inf

22 0.210958 -inf -inf -inf

23 0.220956 -inf -inf -inf

24 0.230954 -inf -inf -inf

25 0.240952 -inf -inf -inf

26 0.250950 -inf -inf -inf

27 0.260948 -inf -inf -inf

28 0.270946 -inf -inf -inf

29 0.280944 -inf -inf -inf

30 0.290942 -inf -inf -inf

31 0.300940 -inf -inf -inf

32 0.310938 -inf -inf -inf

33 0.320936 -inf -inf -inf

34 0.330934 -inf -inf -inf

35 0.340932 -inf -inf -inf

36 0.350930 -inf -inf -inf

37 0.360928 -inf -inf -inf

38 0.370926 -inf -inf -inf

39 0.380924 -inf -inf -inf

40 0.390922 -inf -inf -inf

41 0.400920 -inf -inf -inf

42 0.410918 -inf -inf -inf

43 0.420916 -inf -inf -inf

44 0.430914 -inf -inf -inf

45 0.440912 -inf -inf -inf

46 0.450910 -inf -inf -inf

47 0.460908 -inf -inf -inf

48 0.470906 -inf -inf -inf

49 0.480904 -inf -inf -inf

50 0.490902 -inf -inf -inf

solver_tests_3_trace_couplingSYZ Sweep no trace two trace model S Plot 1

With and Without Trace Coupling

Coupling – Trace

Freq [GHz] db(S(GND,trace_1))
SYZ Sweep all options two trace model

db(S(GND,trace_2))
SYZ Sweep all options two trace model

db(S(trace_1,trace_2))
SYZ Sweep all options two trace model

1 0.001000 -80.094041 -79.939533 -80.268550

2 0.010998 -81.500037 -74.406131 -63.452760

3 0.020996 -79.837461 -69.370202 -58.019106

4 0.030994 -77.104160 -66.019871 -54.757956

5 0.040992 -74.213273 -63.519997 -52.439362

6 0.050990 -71.614311 -61.531155 -50.645301

7 0.060988 -70.062135 -60.043304 -49.143095

8 0.070986 -68.753971 -58.786333 -47.869037

9 0.080984 -67.626534 -57.699034 -46.762601

10 0.090982 -66.637847 -56.741630 -45.784876

11 0.100980 -65.758885 -55.886934 -44.909291

12 0.110978 -64.968820 -55.115593 -44.116836

13 0.120976 -64.252223 -54.413357 -43.393409

14 0.130974 -63.597366 -53.769421 -42.728244

15 0.140972 -62.995129 -53.175396 -42.112926

16 0.150970 -62.438292 -52.624630 -41.540749

17 0.160968 -61.921043 -52.111755 -41.006282

18 0.170966 -61.438639 -51.632369 -40.505065

19 0.180964 -60.987161 -51.182820 -40.033393

20 0.190962 -60.563334 -50.760038 -39.588152

21 0.200960 -60.164395 -50.361418 -39.166703

22 0.210958 -59.787992 -49.984729 -38.766791

23 0.220956 -59.432106 -49.628047 -38.386472

24 0.230954 -59.094988 -49.289698 -38.024060

25 0.240952 -58.775118 -48.968215 -37.678086

26 0.250950 -58.471159 -48.662309 -37.347257

27 0.260948 -58.181934 -48.370838 -37.030433

28 0.270946 -57.906399 -48.092784 -36.726604

29 0.280944 -57.643621 -47.827237 -36.434869

30 0.290942 -57.392766 -47.573381 -36.154421

31 0.300940 -57.153082 -47.330479 -35.884537

32 0.310938 -56.923888 -47.097862 -35.624563

33 0.320936 -56.704568 -46.874923 -35.373909

34 0.330934 -56.494560 -46.661110 -35.132038

35 0.340932 -56.293350 -46.455915 -34.898460

36 0.350930 -56.100465 -46.258873 -34.672731

37 0.360928 -55.915472 -46.069557 -34.454441

38 0.370926 -55.737971 -45.887570 -34.243215

39 0.380924 -55.567591 -45.712547 -34.038708

40 0.390922 -55.403988 -45.544148 -33.840601

41 0.400920 -55.246843 -45.382057 -33.648601

42 0.410918 -55.095858 -45.225980 -33.462434

43 0.420916 -54.950755 -45.075642 -33.281847

44 0.430914 -54.811272 -44.930786 -33.106607

45 0.440912 -54.677165 -44.791169 -32.936492

46 0.450910 -54.548206 -44.656566 -32.771301

47 0.460908 -54.424177 -44.526762 -32.610841

48 0.470906 -54.304875 -44.401557 -32.454934

49 0.480904 -54.190106 -44.280761 -32.303413

50 0.490902 -54.079690 -44.164193 -32.156122

solver_tests_3_trace_couplingAll options two trace model
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With and without Cavity Field Coupling

– Cavity Field coupling models the effect of 
fringe field between cavities

– Two cavities are represented by the 
following stackup

Coupling – Cavity
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With and Without Trace Coupling

– Coupling between the Top Layer, top cavity and bottom layer, bottom cavity

Coupling – Trace

0.00 1.00 2.00 3.00 4.00 5.00
Freq [GHz]

-100.00
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-80.00

-70.00

-60.00
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Ansoft LLC solver_tests_cavity_fields2Without Cavity Field S Plot 1

Curve Info

db(S(Top,lower_cavity))_1
Imported

dB(S(Top,lower_cavity))
Without Cavity Field
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Recommended 
SIwave Solution Settings
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Recommended Settings

SYZ-SI

• Automatic void detection 
preferred

• Enable coupling except intra-
plane coupling

• Disable trace return current 
distribution

• Do not select additional nets 
to include in the simulation

• Use Trace return current 
distribution when signal 
traces switch layers 
frequently (slowdown)
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Recommended Settings

SYZ-RF

• Explicitly set the Plane Void 
Meshing for a low bandwidth 
sweep up to a few GHz

• Enable coupling except intra-
plane coupling

• Disable trace return current 
distribution

• Select additional nets to 
include in the simulation if S-
parameters models are 
attached to components

• Use Trace return current 
distribution when signal 
traces switch layers 
frequently (slowdown)
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Recommended Settings

SYZ-PI

• Automatic void detection 
preferred

• Disable all coupling
• Disable trace return current 

distribution
• Do not select additional nets to 

include in the simulation

• Use do not Explicitly Mesh voids 
< 0mm2 when PI solutions 
contain Hatched Planes 
(Slowdown)

• Use Intra-plane Coupling when 
DC solution accuracy is 
extremely important (RAM 
increase & slowdown)
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Recommended Settings

Near Field

• Select a few frequency points 
only (harmonics)

• Select an observation layer at 
least 3mm away from the PCB
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SIwave Setup Guide for SYZ simulation

• Use the Djordjevic-Sarkar model

• SIwave "standard" dielectrics use Djordjevic-Sarkar by default

• Frequency Sweep

• Include DC point

• Decade sweep from low frequency to around 1GHz

• Linear spaced sweep for 1GHz to highest frequency

• Set highest frequency to a minimum .35/tr where tr is the rise time

• Error Tolerance : Set to .001 (default is .005)

• Impedances

• Set power plane solution impedances to 1 ohm

• Set transmission line solution impedances to 50 ohm

• Exporting s-parameter files

• Renormalize to 50 ohm or 1 ohm according to application.
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Signal Integrity
simulation - Basics
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Signal Integrity Analysis

• SIwave can be used to extract models that accurately model return path, parasitics and 
all relevant coupling .

• Models can be in the form of a Touchstone file (v1.0 and v2.0), FWS SPICE subcircuit, 
lumped RLGC and others, and can be used for any time/frequency analysis 

• SSO

– Verify signaling with non-ideal power delivery to drivers

• Eye diagrams

– Verify signal is clean enough for proper detection

• Cross-talk

– Verify neighbors do not cause excessive noise

• Within SIwave environment, some analyses include Insertion/Return loss, Coupling, 
TDR and TDT, you can view frequency domain data and time domain data using an IFFT
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SI Analysis Setup

Ports are similar to 

probes in lab 

measurements

To Perform a circuit 

extraction or SI 

analysis, place ports 

in desired location
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S-,Y-, Z- Analysis

• To extract S, Y and Z matrix for the predefined
ports :

• Simulation > Compute S-,Y-,Z-parameters

• Enter the value for Start Frequency.
•Include DC point
•Decade sweep from low frequency to 
around 1GHz
•Linear spaced sweep for 1GHz to highest 
frequency
•Set highest frequency to a minimum .35/tr
where tr is the rise time

• Specify the Number of Solution Points.

• Select the method for distributing points

• Choose the sweep Selection

• Discrete sweep

• Interpolating sweep
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Frequency Sweep Selection box

Discrete Sweep : 
• All frequency points in the list are solved. Look at the Frequency List Preview.

Interpolating Sweep :
• Following an Error tolerance, an interpolating sweep estimates a frequency response 

for an entire frequency range by solving at a relatively small number of frequency 
points within that range. Between the actual solution frequencies, the frequency 
response is obtained by rational interpolation. SIwave adaptively chooses the 
frequency points at which it computes the field solution. After a new frequency point 
is solved, a new interpolating fit is generated. This is compared to the interpolant 
from the previous step, and the maximum difference between the two is 
determined. If the difference exceeds the requested tolerance, then a new frequency 
point is chosen for a solution. The interpolating sweep is complete when the 
difference between successive interpolants is less than the error tolerance criterion.

• Optionally, to save these settings and use them for subsequent 
simulations, click the Save Settings button
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Simulation Profile

• During simulation, in the Process Monitor workspace, you can follow the simulation 
progress. profile, monitoring the real time, CPU time, memory requirements and 
view the matrix informations.

• When the simulation is done, the profile is available with real time, CPU 
time, memory requirements and view the matrix informations.

• Results > Analysis Name > View profile
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Frequency Analysis

Verify proper signal 

transmission over desired 

frequency range

Insertion
Return

Coupling
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Signal Net Analyzer
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Signal Net Analyzer (SNA) in SIwave

Receiver IC

Driver IC

A digital signal

U7.(pin)60

U1.(pin)25

SNA provides:
Zo@ void A Zo@ void B

Void A
on return current path

Void B
on return current path

1. Zo Profile & Delay
for all paths of a signal.

2. Reflection Noise
through transient analysis.

Voltage waveform at receiver IC
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• The Signal Net Analyzer gives you the ability to get a quick idea of characteristic impedance and 
also to rapidly generate transient voltage waveforms (using HSPICE or Nexxim simulations) of 
pin-to-pin signal propagation. The Signal Net Analyzer generates an impedance delay plot for 
each trace path selected. It also works for differential pairs.

• Tools > Signal Net Analyzer

Signal Net Analyzer – Impedance Delay
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Signal Net Analyzer – Transient Response
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SIwizard
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SIwizard

Simulation > SIwizard…

Automates the creation of

• Pin groups containing power/ground pins

• Ports on both signal and power nets

• SYZ data (DC to fstop, based on signal TR/TF)

• FWS deck

• AEDT schematic

• Time domain voltage waveforms at drivers, receivers 
and power supply pins of all buffers

• Eye diagrams

Ports / Pin Groups

Select Signal Nets

SYZ

FWS / S-parameters

AEDT Schematic

Transient Simulation / Eye Diagram

A
u

to
m

at
ic
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Step 1: Select Signal Nets

Step 2: Assign IBIS TX/RX Buffers

Step 3: Identify Component  Pwr/Gnd Nets

Step 4: Set Transient Simulation

SIwizard
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Buffer Assignment
Select component in drawing area Set “Class” to IBIS

Set “Type” Select IBIS Component

Correct IBIS buffer model
assigned to all component pins
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Identify Component  Pwr/Gnd Nets

Automated Simulation Setup
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Set Transient Simulation

Automated Simulation Setup



© 2015 ANSYS, Inc. December 7, 2016174

Auto Generated AEDT Project and Transient Simulation 
Results

When Transient Analysis is complete, voltage/currents at the 
PCB terminals are „pushed“ back to the field solver.
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Power Integrity
simulation - Basics



© 2015 ANSYS, Inc. December 7, 2016176

DC Analysis
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SIwave - DC Analysis

• IR Drop

– Verify supplied voltage at all active parts

• Electromigration

– Verify maximum current denisity through vias

• Bottle Necks

– Visualize regions of high current or voltage change

Perforated power and ground planes make for non-ideal DC supply rails

Components with different proximity to VRM will have different supplied voltage

Voltage seen at each load must remain within specified tolerances of chip
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SIwave - DC Solver

• DC Voltage Distributions • DC Current Density Plots

• Adaptive Mesh Refinement• Via and Bondwire Modeling
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I2R Drop

• Setup current sources at all IC loads;

Pin by Pin or Total Current

• Place voltage source at VRM location

Verify min/max voltages 
at all loads
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Total current 

(Itot) flowing 

through 

element

Current limit 

(Ilim) (see next 

page) 

Electromigration check:

“Pass” if Itot <= Ilim

“Fail” otherwise  

Elctromigration

• Globally scan all vias and bondwires

• Reduce current density by adding additional vias to vicinity
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Bondwire/Via Current Limit

Define current limit (Ilim) as value above which electromigration
is likely to be a problem

Computed using simple Ilim = tA formula

• t (A/m2): user-editable value in “dc_coeff.txt” (located in the 
SIwave V5 installation directory)

• A: cross-sectional area of conductor

Bondwire: A = pr2 Via: A = p(ro
2 – ri

2)

r rori
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Bottlenecks

Visualize where design 
improvements could be made

Current Density
Voltage Distribution

High Current Low Voltage
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SIwave - Zoom to problem Areas

Visualize Current on 
all layers to help 
determine a solution

INCLUDING 
The GND 
RETURN 
PATH
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Define Equipotential Regions for DC IR

• Equipotential regions are used by the DC IR drop solver to force equal 
voltage across a specified region, including specified pads.

• To define equipotential regions, click Draw>Equipotential Regions

• The cursor is activated to draw a rectangle. Use the menu selection to 
draw one or more regions on the Top or Bottom of the layout.

– Hide all layers to see the regions

• Use the Delete All Regions button to erase any previously-defined regions
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Resonant Modes Analysis
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Resonance Simulation

Eigenmode analysis identifies location and frequency of natural cavity 
resonances that exist between planes

Scans entire PCB/PKG on all layers

If a resonance is excited, Signal Integrity can be compromised : 

• High Z, null in S21, EMI etc.

Resonances should be moved away from critical parts and outside operating 
frequency

Reducing Resonance :

• Resonances always exist but  you can reduce their impact by:
– Changing the decoupling scheme

– Changing the stackup

– Changing plane dimensions

– Adding via stitching

– Moving discrete parts
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Resonance Simulation : Rectangular Cavity

Structure: two metal planes, 60mm x 40mm

Dielectric: FR4 (er = 4.4, tan d = 0), 1 mm thick

Analytic solutions for voltage at resonance:

Analytic solutions for resonance frequencies:

)/cos()/cos(),( bymaxnyxv pp ,3,2,1, mn

22

0

2



















b

m

a

ncc
f

rmn

nm


m,n SIwave (GHz) Analytic (GHz)

1,0 1.192615376 1.19182823655

0,1 1.790103257 1.78774235483

1,1 2.154560548 2.14859890922

2,0 2.397284602 2.38365647311

2,1 3.000732847 2.97957059139



© 2015 ANSYS, Inc. December 7, 2016188

SIwave Resonance Analyse

• Easy setup, no sources are required. To solve the resonant mode of the cavity 
using the Eigenmode solver :

– Simulation > Compute Resonant Modes.
– Enter the value for Minimum Frequency. 

– Enter the value for Maximum Frequency. 
• You can leave this field blank.

– Specify the # of Modes to Compute. 
• The modes indicate the frequencies at which the cavity 

responds very strongly. This determines the voltage pattern 
between the top and bottom planes.

– OK
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Resonance Mode results

Each mode is computed as well as several 
parameters.

• Re{f} corresponds to the frequency at 
which it will oscillate.

• Im{f} corresponds to the loss

• Wavelength(in vacuum) = c / Re{f}

• K = 2*pi / Wavelength

• Q = Re{f} / (2*pi*Im{f})

Display Voltage distribution between planes 
at resonance

• Red and blue areas indicate high impedances 
at a particular frequency

• Viewing Phase Animation
– Select Metals plane

– Compute

– Generate Frames
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Frequency Sweep Analysis
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Frequency Sweep Analysis Review

• Although resonant modes are inevitable, they may or may not be 
excited depending on the location of the source.  

• With the Frequency Sweep Analysis, the designer can excite the 
design in specified locations and see the aggregate response of all 
the resonant modes of the board for the given source location.

• Verify maximum IR drop across frequencies
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SIwave Analyses

Frequency Sweep
• Current or voltage sources

• Voltage distribution at all desired frequencies.

• Voltage probes for quantitative dependence.
Sweep from DC to 
2 GHz
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Why Resonances Mode Analysis?

S

S
Board Edge

Plane

V

• Return path current is disrupted at the via.

• Signal vias couple to the planes. 

• Creates a feed for the parallel plate waveguide.

Plane
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Simple SIwave Experiment

Control Case :

• Microstrip transmission line without 
a via transition

Test Case :

• Same length transmission line with a 
via transition from top to bottom

1 V Sources 50 Ohm Term

Vias

4 Layer 8x10” PCB
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343 MHz 441 MHz 553 MHz

Control Case

343 MHz 441 MHz 553 MHz

Test Case

• The blue and the red represent the resonance points. Where green has no 
resonance.

Resonance Results
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Far Fields at 3 Meters
d

B
u

V

GHz

343 MHz

553 MHz

Spikes in far- fields only 
occur for resonances that 
have a via transition 
through them

441 MHz

441 MHz 553 MHz343 MHz
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Computing Impedance of 
PDN using S-,Y-, Z- Analysis
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Plane impedance Simulation

PWR Impedance
PWR net without decaps

PWR net with decaps

Ztarget

Fmax

MASK Spec.

• Same setup as S-Parameter extraction. Place ports in locations of interest. 
Pin Grouping can be useful

• Verify low impedance up to device cut-off frequency
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SIwave : Grouping Pins

You can create pin groups for various components. The grouped pins will be treated as if 
they were electrically connected during the analysis.

You can use this pin group to create ports

• Tools > Create/Manage Pin Groups...

• Double click on the IC component in the 3D modeler
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Pin grouping port between different
components

Create a Pin Group from multiple components:

Multi-select Pins in GUI

• RT click -> Create/Manage Pin Groups…



© 2015 ANSYS, Inc. December 7, 2016201

S-,Y-, Z- Analysis

• To extract S, Y and Z matrix for the 
predefined ports :

• Simulation > Compute S-,Y-,Z-parameters

• Enter the value for Start Frequency.

• Set the stop frequency or rise time 
information

• (Frequency Bandwith= 0.5/min rise time)

• Specify the Number of Solution Points.

• Select the method for distributing points

• Choose the sweep Selection

• Discrete sweep

• Interpolating sweep



© 2015 ANSYS, Inc. December 7, 2016202

Frequency Sweep Selection box

Discrete Sweep : 
• All frequency points in the list are solved. Look at the Frequency List Preview.

Interpolating Sweep :
• Following an Error tolerance, an interpolating sweep estimates a frequency response 

for an entire frequency range by solving at a relatively small number of frequency 
points within that range. Between the actual solution frequencies, the frequency 
response is obtained by rational interpolation. SIwave adaptively chooses the 
frequency points at which it computes the field solution. After a new frequency point 
is solved, a new interpolating fit is generated. This is compared to the interpolant
from the previous step, and the maximum difference between the two is 
determined. If the difference exceeds the requested tolerance, then a new frequency 
point is chosen for a solution. The interpolating sweep is complete when the 
difference between successive interpolants is less than the error tolerance criterion.

Optionally, to save these settings and use them for subsequent simulations, 
click the Save Settings button
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Simulation Profile

• During simulation, in the Process Monitor workspace, you can follow the simulation 
progress. profile, monitoring the real time, CPU time, memory requirements and 
view the matrix informations.

• When the simulation is done, the profile is available with real time, CPU 
time, memory requirements and view the matrix informations.

• Results > Analysis Name > View profile
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Sensitivity Analysis
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Sensitivity Analysis

Sensitivity analysis computes the derivative of a circuit response (an S-, Y- or Z-parameter) 
with respect to the impedance of a circuit element, typically a decoupling capacitor.

Therefore it is a measure of how much that output parameter will change in response to a 
change in the circuit element.

• A low sensitivity indicates that the circuit element has little influence on the circuit 
response of interest

• A high sensitivity indicates that the response is a strong function of the circuit element. 

This information can help a designer to identify which circuit elements need to be adjusted 
to improve a circuit response. It can be used to find unnecessary decoupling capacitors-
-ones that aren't affecting the results significantly. It can also help to identify which 
circuit elements need loose or tight tolerances.
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Sensitivity Analysis

• Advantages :

• Sensitivity analysis can be computed very quickly for a large number of circuit 
elements once you have solved for the nominal S-parameters.

• Using the built-in sensitivity analysis capability, you can reduce that time to a 
small fraction (perhaps 5%) of the analysis time for the nominal problem. It is 
essentially "free" information
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Sensitivity Analysis in details

The software internally computes the derivative the circuit responses that you designate with 
respect to the impedance of the circuit elements you choose. To make this more concrete, 
suppose you pick an Sparameter  Sij and a capacitor C . The impedance of the capacitor is 
Zc=jwC . So the software computes the derivative, dSij/dZc. 

This "raw" derivative is then normalized as follows to make it easier to interpret:

• As shown in the formula above, the normalized sensitivity can be interpreted as the ratio of the 
fractional change in the output parameter to the fractional change in the impedance of the 
circuit element. So if the normalized sensitivity is 10, that would indicate that a 1% change in the 
capacitor’s impedance would result in a 10% change in the output S-parameter. Normalized 
sensitivity makes it easy to compare the sensitivities of circuit elements with widely varying 
impedances.

• The normalized sensitivity is a complex number. The software reports the magnitude of the 
normalized sensitivity, so what you see in the user interface is a real number.
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Capacitors Name Visibility

Change visibility settings for element names :
• Visibility > Labels > Capacitors

Adjust the size of the text
• Visibility > Labels > Change Text Attributes…
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Set sensitivity computation for capacitors, inductors 
and inductors

Edit > Circuit Element Parameters.

• Select capacitors that will be available for sensitivity analysis

• Simulation > Compute SYZ parameters

• Check Matrix entry  in Sensitivity tab
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Results >SYZ > Plot Sensitivity

Here, the max normalized sensitivity is 26.8 for C71 :
• It indicate that a 1% change in the capacitor’s impedance would result in a 26.8% 

change in the output Z-parameter.
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Power Distribution System & 
PI Methodology
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Power Distribution System

PDS Design Goal:

• Reduce noise in the power distribution system to a level that is
acceptable for system performance.

• System Engineer

• Active Device Current Spectrum

• Power Distribution Impedance Specification

I()

V()

Z()=

Acceptable Ripple Voltage

Current Spectrum

Target Impedance
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High-Speed 
Digital Device

Power 
Delivery SystemV

I

1MHz1KHz

Switching 
Power Supply

Electrolytic Bulk 
Capacitors

High Frequency 
Ceramic 
Capacitors

Power/Ground

Planes

Buried Capacitance

1 GHz
100MHz

Log(f)

|Z()|

1. The Impedance looks into PDS at the device should be kept low over a broad frequency range 
(from DC to package cut-off frequency)!

2. The Desired Frequency Range and Impedance Value is called Target Impedance.

3. Target impedance goal is set with the help of allowable ripple on the power/ground plane over 
a specified frequency range.

Ztarget()=
I()

V()

Target Impedance of PDS
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• Target Impendence is the goal that designers should hit!

   
Current

RippleAllowedVoltageSupplyPower
Z

___
Target




   



 m

A

V
Z 1.3

3.40

%55.2
v)Target(2.5

*Source: International  Technology Roadmap for Semiconductors

*Target Impedance is falling ~ 1.6x, every 3 years

Target Impedance Calculation  & Trends
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Impedance consists of

• Capacitive factor, decreases with frequency

• Inductive factor, increases with frequency

• Inductance includes plane inductance, ESL of decoupling 
capacitors, traces and vias which connect planes to capacitors

Components of Z

Cfp2

1

Lfp2

f

|Z|

Mag. of Z

target
Z

Inductive 

area

Capacitive 

area

Bulk 

Capacitance
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Low frequency:

VRM few HZ

large caps 10 -100 KHz
Low Inductance BGA caps 

0603, 0805, 1206 die/land slide

Frequencies higher than PCB

BGA Package

Low Inductance Capacitor on Package

Ball Bonding

Discrete Decoupling Capacitor on PCB

Bulk Capacitor

Ground

Power

VRM

Chip

PCB

P/G Network

Bulk Capacitor

Near VRM

Package

Solderballs

Decoupling Capacitor

On Package

Package

P/G Network

Die

Bumps

Decoupling Capacitor

On Chip

Chip

VDD

VSS

Decoupling Capacitor

On PCB

Driver/ Receiver Model

VRM

Core Power Delivery Network



© 2015 ANSYS, Inc. December 7, 2016217

Merging Package 
on Board
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• Tools > Attach Package Design…

• Some recommendations :
• The project of the board must be opened

• Identify the package location.

• Identify the Part Name, Designator Name of the Package.

• Identify a specific net in the board and package side to know if a 
rotation is needed.

• Package Padstack

Connect a package onto a PCB
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Connect a package onto a PCB
• Enter the Package Path

• Select the solderballs model and parameters

• Select the PCB Part Name and PCB Reference Designator 

• Align pins using pins selection

• Automatic

• Select Merging options

• Merge Layers

• Merge nets

• Generate solderballs

• Execute Merge

3

5

6

1

2 4
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Workshops

WS06_0_siwave_pkg_pcb_merge.pdf
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Chip-Package-PCB  Co-Design
using S-Parameters
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• Redhawk generates a chip power 
model (CPM) including chip PDN 
parasitics and switching currents.

• SIwave provide robust extraction 
of IC packages and boards with 
broadband S-parameter models.

• PI Advisor optimizes decoupling 
capacitor selection to meet a 
target impedance.

• AEDT simulates power noise in the 
time domain.

ANSYS Chip-Aware PDN Solution

0.00 2.00 4.00 6.00 8.00 10.00
Time [ns]

1.450

1.475

1.500

1.525

1.550

V
(u

1
_

v
c
c
) 

[V
]

CPM CurrentU1 VCC
Curve Info min max pk2pk avg

V(u1_vcc)
NexximTransient

1.4507 1.5489 0.0982 1.4946
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Each C4 bump (power & ground) 
will be associated to its corresponding:

Chip PDN RLC  
Physical model of chip layout

Transistor/cell current /cap/ESR 
Electrical model of chip layout

CPM is topological, 
physical and activity based

PCB + Package

What’s in a CPM?
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Traditional Die Model

RedHawk (SoC)

Layout

Chip Power Model

 RLC reduction: billions of 
parasitics to thousands of Spice 
elements

 Distributed with full couplings

Apache CPM™

Library

C
h

ip
 C

u
rr

e
n

t
C

h
ip

 P
ar

as
it

ic
s

Traditional die model

Single Lumped Model

Apache CPM

Benefits of CPM
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• Import of die PDN for 
inclusion in frequency-
domain extractions

• Automatic matching of die 
pin to CPM pin locations

SIwave CPM Integration

• SIwave CPM integration includes the following:
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SIwave CPM Setup
• Select the device footprint in the SIwave layout 
• File > Import > Apache CPM/PLOC file…

• Browse to the CPM file 
• Click the Auto Connect button to attach SIwave footprint pins to the CPM pins.
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analysis_v2PDN Impedance at Die
Curve Info

mag(Z(FCHIP_VDD_15,FCHIP_VDD_15))
SYZ Sw eep 1

mag(Z(FCHIP_VDD_15,FCHIP_VDD_15))
SYZ Sw eep 2

SIwave CPM Setup
• CPM Impedance Effect
• There is a significant effect at a broad frequency range due to the high total 

capacitance present on this chip.

PKG
PKG+CPM
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AEDT , SIwave, and CPM

• Drive VDDs with CPM

• Capture coupled high-
frequency noise

• Run Near/Far-Field 
Simulations using transient 
results

SIwave
Model

CPM
Model

Terminations
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AEDT  Transient Results

Vripplevoltage
swing

DC IR Drop

IC die model with merged package and PCB

IC die model with package only

VDD Noise (mV) Settling Time Comparison
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Simulation approaches

• The PI methodology is different depending on the needs. We can
considered two simulation approaches.

– « Free optimization » of a design (The location, mounting style, 
value, number and type of capacitors are not predefined ).

– « Fixed » optimization of an existing design. The location of 
capacitors are already fixed (footprint defined as discrete device 
during database import).  The max number of capacitor is also 
predefined.
• PI Optimization using SIwave and ANSYS AEDT (Iterative Approach)

• PI Optimization using PIadvisor (An Automated Approach)
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Free optimization of a design

• Place Probe on different power nets to scan all the frequency range. EM 
extraction of impedance for critical devices :

• SYZ analysis

• Compare to the defined target

• Resonances analysis is performed to evaluate problems on power planes 
and helping the placement of decoupling capacitors :
• Resonance and frequency sweep analysis

• Choose some decoupling capacitors to move the resonances in terms of Impedance 
magnitude and Resonance frequency 

• Capacitor Library Browser

• Place  them close to the resonance peaks

• The final step is to simulate in time domain to check for compliance. 
Look at the Switching Power Noise

• Transient simulation in AEDT
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The Capacitor Library Browser
• Explore and plot the impedance of various vendor or imported capacitor components 

versus frequency and quickly determine the lumped circuit equivalent  (Included with 
SIwave)

– Tools > Capacitor Library Browser
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PI Optimization using SIwave and ANSYS 
AEDT (Iterative Approach)

• A very useful technique for evaluating the effectiveness of the capacitors and there 
locations is to extract the model into AEDT. 

• In SIwave, place a port at the IC and replace the capacitors you are interested in 
optimizing with a port.

• After, run a SYZ simulation and import the s-parameters into AEDT. 

• Place a port again at the IC terminal and connect the capacitors from the other 
terminals to ground.

• Now, when you run a linear network analysis, you can see the same results as in 
SIwave but it will be much quicker. 

• This allows you to try many different combinations of capacitors and optimize them.
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PIAdvisor
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SimplePI using Capacitor
Library Browser
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The Capacitor Library Browser (1/2)

Explore and plot the impedance of various vendor or imported capacitor 
components versus frequency and quickly determine the lumped circuit 
equivalent  (Included with SIwave)

• Tools > Capacitor Library Browser
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The Capacitor Library Browser (2/2)

• Automatically determine the best type and number of capacitors given a 
frequency dependent impedance mask and mount capacitors at certain user-
defined capacitor regions. 

• (PIadvisor is mandatory)

• Define VRM parameters, Load an impedance Mask and then Run « Auto select 
capacitors required to match impedance profile »



© 2015 ANSYS, Inc. December 7, 2016238

Matching process

• Two Statistics are provided, Siwave optimize the numbers of capacitors
used and the types.
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Mount the provided solution in the existing design

• Select « Mount active Capacitors in design »

• 4 steps are required to mount a capacitor.

1

2

3

4
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Mount the provided solution in the existing
design ( 3/4 steps)

For each unmounted capacitors, SIwave allow you to 
choose :

• The Mounting style (2 via Tall or 2 via Wide) 

• Define the Capacitors Mount Dimensions

• Define the connected nets

1

2
3
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Mount the provided solution in the 
existing design ( 4/4 steps)

The last step to allow the mounting is to define a capacitor region on the layout
:

• Draw > Capacitor regions…
– Select the top or bottom region

• Use the mouse to draw a rectangle

ie : 2 regions
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Mount the provided solution in the 
existing design ( Final step)

Select the pre-defined regions and Unmounted Capacitors and click « Mount 
Selection » 

• Note : If some capacitors can not be mount due to 
their size / area constraints, the following message 
appears.
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PIAdvisor – PI Optimization
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Power Integrity Design

PCB Geometry present

• A functional design, with all decoupling capacitors already placed on PCB 

• PI Engineer may want to:
– Increase capacitor count in order to make design more robust (i.e. overclocking, etc.)

– Reduce the capacitor count

– Reduce number of different capacitor types used

– Redesign using lower cost capacitors

– Chose appropriate capacitor location
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PI Advisor

Automated PI Optimization : An Automated Approach 
to investigate into Decoupling Analysis.

• Simulation > PIadvisor…

• A functional design, with all decoupling 

capacitors already placed on PCB 

• PI Engineer may want to:

– Increase capacitor count in order

to make design more robust

– Reduce the capacitor count

– Reduce number of different capacitor types used

– Redesign using lower cost capacitors

– Chose appropriate capacitor location
Genetic Algorithm Setup

Optimized for Impedance
Optimized for # of Caps
Optimized for Capacitor Types
Optimized for Price
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Automated PI Optimization 
5 Easy Steps

1. Define Ports and Impedance Targets

or
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Automated PI Optimization
5 Easy Steps

2. Select Capacitors for Automated Optimization
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Automated PI Optimization
5 Easy Steps

3. Select Candidate Capacitors for Optimizer
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How to Determine Candidate Capacitors

1. User choice based off of BOM

• Enter capacitor selections

2. User choice based off of filtered selection

3. Automated selection using SimplePI
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Automated PI Optimization
5 Easy Steps

4. Setup Optimization Criteria

• Total Price

• Total Number of Caps

• Total Number of Cap Types

• Total Capacitor Area

• SYZ Sweep

5. Launch Optimizer and Analyze Results
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Optimized Results
Without Embedded Capacitance

Time = 15min 7sec
• Frequency Setup

– 1KHz <= f < 1GHz
– 50 Points/decade

• Genetic Algorithm Setup
– Optimized for Impedance
– Optimized for # of Caps
– Optimized for Capacitor Types
– Optimized for Price
– 100 Members
– 1000 Iterations

Original solution
• Total # Caps: 74
• Capacitor types: 

– All ideal

Optimized Solution
• Total # Caps: 18
• Capacitor Types = 5

– AVX, Samsung, and Kemet
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Loop inductance

After running an optimization in PI advisor right-click the PI Advisor Simulation name in 
the Results workspace to obtain the loop inductance between each port/capacitor

Provides intuitive plot to analyze capacitor layout thereby minimizing loop inductance
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EMI/ EMC simulation 
Basics
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EMC Analysis

First design and optimize PDS

• Low plane impedance 

• Minimal resonances

Perform FFT of transient waveforms

• Add current/voltage sources at IC locations

• Measure Near/Far fields in Frequency band of interest

Place PCB/PKG in enclosure model

• Plot fields using HFSS

• Measure effects of shielding 
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SIwave Analyses

Far/Near-field Calculation
• Explicit field is calculated from SIWave 

solution

• Far/Near-field Green‘s function is used to 
determine fields in all space.

Far-field maximum |E|

|H| 3mm above board

1.0E-5 A/m

1.0E-9 A/m
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SIwave - Near Fields 

MeasurementSiwave v4.0

Near Field correlation - 60mm slot length
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SIwave - Far Field Plotting

M
a

g
.E

 (
d

B
u

V
/m

) 
@

3
m

Emission test plot @ 3m

Add sources to 

physical location 

of ICS and specify 

max current draw 

or voltage

Spikes 

correspond 

to excited 

resonance 

modes
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Shielding Analysis

Dynamically link 

SIwave to HFSS to 

plot the field strengths 

around the enclosure

SIwave field 

solution can be 

used as a 

radiation source 

for HFSS
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System Analysis (Verification)

• Design Setup for System Analysis

Import PCB and
Component Definitions
from 3rd Party Layout

Resonance
Analysis

Full-wave Extraction Set up 
Drivers/Receivers

Schematic 
generation

Transient circuit 
analysis

Near and Far-field 
Calculation



© 2015 ANSYS, Inc. December 7, 2016260

What is a Full System EMI/EMC Methodology

State of the art EMI/EMC simulation method that
• Utilizes the best in class tools

• Incorporates physical board layouts

• Uses real world transient signals

• Takes into account full 3D enclosures

• Seamlessly combines frequency and time domain simulation tools to 
predict EMI

What are the tools needed?
• Board analysis > SIwave

• Full 3D enclosure > HFSS

• Realistic clock/timing, and digital signals > AEDT

• CAD links > ALinks
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What are the steps ?

1. Import PCB layout into ALinks or SIwave

2. Perform analysis of PCB in Siwave

3. Dynamically link SIwave results into ANSYS Electronics Desktop (AEDT) – Circuit 
Design

4. Attach drivers and receivers in AEDT to linked SIwave model

5. Perform a time/frequency domain analysis of entire system in AEDT

6. Push voltage/excitation levels back to SIwave

7. Dynamically link the SIwave model into AEDT – HFSS Design

8. Solve the full system in AEDT – HFSS Design
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The SIwave simulation

1) Layout in eCAD tool is imported into SIwave

1a) Simulation is setup 
and run
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The AEDT Simulation

0.00 3.50

1.08 1.10 1.12 1.14 1.16 1.18
Time [us]

0.00

0.50

1.00

1.50

2.00

2.50

Y
1

 [
V

]

Ansoft LLC Nexxim1Rcvr Pattern

Curve Info

V(Rcvr)

Transient

 0.00 50.00 100.00 150.00 200.00 250.00 300.00 350.00 400.00 450.00 500.00
Spectrum [MHz]

-100.00

-80.00

-60.00

-40.00

-20.00

-0.00

20.00

d
B

(V
(R

c
v
r)

)

Ansoft LLC Nexxim1Frequency_Spectrum

m1

m2

m3

m4

m5

m6

m7

m8

m9

m10 m11

m12

m13

m14

Name X

Curve Info

dB(V(Rcvr))

2) SIwave model is 
dynamically linked into 
AEDT

2a) Drivers and 
receivers are     
added to the      
circuit and    
simulated

Driver Receiver
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Back to SIwave

3) Results from AEDT 
are pushed back into 
SIwave

3a) Fields near to the 
PCB are calculated
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Linking to HFSS

4) Siwave results are 
dynamically linked  
into HFSS model

4a) HFSS model is solved
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Finishing the System Simulation

5) Entire System is 
solved in HFSS.

5a) Results are plotted
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Workshops

Siwave_radiation.pdf

Siwave_dynamic_link.pdf
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https://support.ansys.com/portal/site/AnsysCustomerPortal/

Registration and login information can be requested from us

Accessing the ANSYS Customer Portal

https://support.ansys.com/portal/site/AnsysCustomerPortal/

